Tue, 22 Sep 2020 05:34:00 UTC

Information for build pacemaker-2.0.0-5.fc29

ID1253885
Package Namepacemaker
Version2.0.0
Release5.fc29
Epoch
Sourcegit+https://src.fedoraproject.org/rpms/pacemaker.git#a66a6e965d555ec690ebe4e9d308326832554d25
SummaryScalable High-Availability cluster resource manager
DescriptionPacemaker is an advanced, scalable High-Availability cluster resource manager. It supports more than 16 node clusters with significant capabilities for managing resources and dependencies. It will run scripts at initialization, when machines go up or down, when related resources fail and can be configured to periodically check resource health. Available rpmbuild rebuild options: --with(out) : coverage doc hardening pre_release profiling
Built byjpokorny
State complete
Volume fedora_koji_archive04
StartedTue, 23 Apr 2019 19:37:14 UTC
CompletedTue, 23 Apr 2019 20:04:25 UTC
Taskbuild (f29-candidate, /rpms/pacemaker.git:a66a6e965d555ec690ebe4e9d308326832554d25)
Extra{'source': {'original_url': 'git+https://src.fedoraproject.org/rpms/pacemaker.git#a66a6e965d555ec690ebe4e9d308326832554d25'}}
Tags
f29-updates
RPMs
src
pacemaker-2.0.0-5.fc29.src.rpm (info) (download)
aarch64
pacemaker-2.0.0-5.fc29.aarch64.rpm (info) (download)
pacemaker-cli-2.0.0-5.fc29.aarch64.rpm (info) (download)
pacemaker-cluster-libs-2.0.0-5.fc29.aarch64.rpm (info) (download)
pacemaker-libs-2.0.0-5.fc29.aarch64.rpm (info) (download)
pacemaker-libs-devel-2.0.0-5.fc29.aarch64.rpm (info) (download)
pacemaker-remote-2.0.0-5.fc29.aarch64.rpm (info) (download)
pacemaker-cli-debuginfo-2.0.0-5.fc29.aarch64.rpm (info) (download)
pacemaker-cluster-libs-debuginfo-2.0.0-5.fc29.aarch64.rpm (info) (download)
pacemaker-debuginfo-2.0.0-5.fc29.aarch64.rpm (info) (download)
pacemaker-debugsource-2.0.0-5.fc29.aarch64.rpm (info) (download)
pacemaker-libs-debuginfo-2.0.0-5.fc29.aarch64.rpm (info) (download)
pacemaker-remote-debuginfo-2.0.0-5.fc29.aarch64.rpm (info) (download)
armv7hl
pacemaker-2.0.0-5.fc29.armv7hl.rpm (info) (download)
pacemaker-cli-2.0.0-5.fc29.armv7hl.rpm (info) (download)
pacemaker-cluster-libs-2.0.0-5.fc29.armv7hl.rpm (info) (download)
pacemaker-libs-2.0.0-5.fc29.armv7hl.rpm (info) (download)
pacemaker-libs-devel-2.0.0-5.fc29.armv7hl.rpm (info) (download)
pacemaker-remote-2.0.0-5.fc29.armv7hl.rpm (info) (download)
pacemaker-cli-debuginfo-2.0.0-5.fc29.armv7hl.rpm (info) (download)
pacemaker-cluster-libs-debuginfo-2.0.0-5.fc29.armv7hl.rpm (info) (download)
pacemaker-debuginfo-2.0.0-5.fc29.armv7hl.rpm (info) (download)
pacemaker-debugsource-2.0.0-5.fc29.armv7hl.rpm (info) (download)
pacemaker-libs-debuginfo-2.0.0-5.fc29.armv7hl.rpm (info) (download)
pacemaker-remote-debuginfo-2.0.0-5.fc29.armv7hl.rpm (info) (download)
i686
pacemaker-2.0.0-5.fc29.i686.rpm (info) (download)
pacemaker-cli-2.0.0-5.fc29.i686.rpm (info) (download)
pacemaker-cluster-libs-2.0.0-5.fc29.i686.rpm (info) (download)
pacemaker-libs-2.0.0-5.fc29.i686.rpm (info) (download)
pacemaker-libs-devel-2.0.0-5.fc29.i686.rpm (info) (download)
pacemaker-remote-2.0.0-5.fc29.i686.rpm (info) (download)
pacemaker-cli-debuginfo-2.0.0-5.fc29.i686.rpm (info) (download)
pacemaker-cluster-libs-debuginfo-2.0.0-5.fc29.i686.rpm (info) (download)
pacemaker-debuginfo-2.0.0-5.fc29.i686.rpm (info) (download)
pacemaker-debugsource-2.0.0-5.fc29.i686.rpm (info) (download)
pacemaker-libs-debuginfo-2.0.0-5.fc29.i686.rpm (info) (download)
pacemaker-remote-debuginfo-2.0.0-5.fc29.i686.rpm (info) (download)
noarch
pacemaker-cts-2.0.0-5.fc29.noarch.rpm (info) (download)
pacemaker-doc-2.0.0-5.fc29.noarch.rpm (info) (download)
pacemaker-nagios-plugins-metadata-2.0.0-5.fc29.noarch.rpm (info) (download)
ppc64le
pacemaker-2.0.0-5.fc29.ppc64le.rpm (info) (download)
pacemaker-cli-2.0.0-5.fc29.ppc64le.rpm (info) (download)
pacemaker-cluster-libs-2.0.0-5.fc29.ppc64le.rpm (info) (download)
pacemaker-libs-2.0.0-5.fc29.ppc64le.rpm (info) (download)
pacemaker-libs-devel-2.0.0-5.fc29.ppc64le.rpm (info) (download)
pacemaker-remote-2.0.0-5.fc29.ppc64le.rpm (info) (download)
pacemaker-cli-debuginfo-2.0.0-5.fc29.ppc64le.rpm (info) (download)
pacemaker-cluster-libs-debuginfo-2.0.0-5.fc29.ppc64le.rpm (info) (download)
pacemaker-debuginfo-2.0.0-5.fc29.ppc64le.rpm (info) (download)
pacemaker-debugsource-2.0.0-5.fc29.ppc64le.rpm (info) (download)
pacemaker-libs-debuginfo-2.0.0-5.fc29.ppc64le.rpm (info) (download)
pacemaker-remote-debuginfo-2.0.0-5.fc29.ppc64le.rpm (info) (download)
s390x
pacemaker-2.0.0-5.fc29.s390x.rpm (info) (download)
pacemaker-cli-2.0.0-5.fc29.s390x.rpm (info) (download)
pacemaker-cluster-libs-2.0.0-5.fc29.s390x.rpm (info) (download)
pacemaker-libs-2.0.0-5.fc29.s390x.rpm (info) (download)
pacemaker-libs-devel-2.0.0-5.fc29.s390x.rpm (info) (download)
pacemaker-remote-2.0.0-5.fc29.s390x.rpm (info) (download)
pacemaker-cli-debuginfo-2.0.0-5.fc29.s390x.rpm (info) (download)
pacemaker-cluster-libs-debuginfo-2.0.0-5.fc29.s390x.rpm (info) (download)
pacemaker-debuginfo-2.0.0-5.fc29.s390x.rpm (info) (download)
pacemaker-debugsource-2.0.0-5.fc29.s390x.rpm (info) (download)
pacemaker-libs-debuginfo-2.0.0-5.fc29.s390x.rpm (info) (download)
pacemaker-remote-debuginfo-2.0.0-5.fc29.s390x.rpm (info) (download)
x86_64
pacemaker-2.0.0-5.fc29.x86_64.rpm (info) (download)
pacemaker-cli-2.0.0-5.fc29.x86_64.rpm (info) (download)
pacemaker-cluster-libs-2.0.0-5.fc29.x86_64.rpm (info) (download)
pacemaker-libs-2.0.0-5.fc29.x86_64.rpm (info) (download)
pacemaker-libs-devel-2.0.0-5.fc29.x86_64.rpm (info) (download)
pacemaker-remote-2.0.0-5.fc29.x86_64.rpm (info) (download)
pacemaker-cli-debuginfo-2.0.0-5.fc29.x86_64.rpm (info) (download)
pacemaker-cluster-libs-debuginfo-2.0.0-5.fc29.x86_64.rpm (info) (download)
pacemaker-debuginfo-2.0.0-5.fc29.x86_64.rpm (info) (download)
pacemaker-debugsource-2.0.0-5.fc29.x86_64.rpm (info) (download)
pacemaker-libs-debuginfo-2.0.0-5.fc29.x86_64.rpm (info) (download)
pacemaker-remote-debuginfo-2.0.0-5.fc29.x86_64.rpm (info) (download)
Logs
x86_64
state.log
hw_info.log
build.log
root.log
mock_output.log
noarch_rpmdiff.json
ppc64le
hw_info.log
state.log
build.log
root.log
mock_output.log
noarch_rpmdiff.json
aarch64
build.log
root.log
hw_info.log
state.log
mock_output.log
noarch_rpmdiff.json
i686
hw_info.log
build.log
state.log
root.log
mock_output.log
noarch_rpmdiff.json
s390x
hw_info.log
state.log
build.log
root.log
mock_output.log
noarch_rpmdiff.json
armv7hl
state.log
build.log
hw_info.log
root.log
mock_output.log
noarch_rpmdiff.json
Changelog * Tue Apr 23 2019 Jan Pokorný <jpokorny+rpm-pacemaker@redhat.com> - 2.0.0-5 - Apply fixes for security issues: . CVE-2019-3885 (use-after-free with potential information disclosure) . CVE-2018-16877 (insufficient local IPC client-server authentication) . CVE-2018-16878 (insufficient verification inflicted preference of uncontrolled processes) * Thu Aug 23 2018 Jan Pokorný <jpokorny+rpm-pacemaker@redhat.com> - 2.0.0-4 - Sanitize/generalize approach to Python byte-compilation, so that also out-of-Python-path *.py files (%{_datadir}/pacemaker/tests/cts/CTSlab.py in particular) get the expected treatment now * Wed Aug 15 2018 Jan Pokorný <jpokorny+rpm-pacemaker@redhat.com> - 2.0.0-3 - Fix Python 3.7 incompatibility (otherwise missed in bytecompilation phase, see rhbz#1616219) * Thu Aug 09 2018 Jan Pokorný <jpokorny+rpm-pacemaker@redhat.com> - 2.0.0-2 - Include fix for "cibadmin --upgrade" related issues (rhbz#1611631) - Adapt spec file more akin to upstream version including: . assuredly skip servicelog-related binaries even when build-time prerequisites are present on suitable systems (9f24448d8) * Mon Jul 09 2018 Jan Pokorný <jpokorny+rpm-pacemaker@redhat.com> - 2.0.0-1 - Update for new upstream tarball: Pacemaker-2.0.0, for full details, see included ChangeLog file or https://github.com/ClusterLabs/pacemaker/releases/tag/Pacemaker-2.0.0 * Mon Jul 02 2018 Miro Hrončok <mhroncok@redhat.com> - 2.0.0-0.1.rc6.1 - Rebuilt for Python 3.7 * Thu Jun 28 2018 Jan Pokorný <jpokorny+rpm-pacemaker@redhat.com> - 2.0.0-0.1.rc6 - Update for new upstream tarball for release candidate: Pacemaker-2.0.0-rc6, for full details, see included ChangeLog file or https://github.com/ClusterLabs/pacemaker/releases/tag/Pacemaker-2.0.0-rc6 - Adapt spec file more akin to upstream version including: . new procps-ng and psmisc dependencies with -cli and -cts, for e.g. "ps/sysctl/uptime" and "killall" invocations, respectively (a4ad8183a) . move crm_node to -cli (a94a1ed58) * Tue Jun 19 2018 Miro Hrončok <mhroncok@redhat.com> - 2.0.0-0.1.rc5.1 - Rebuilt for Python 3.7 * Fri Jun 01 2018 Jan Pokorný <jpokorny+rpm-pacemaker@redhat.com> - 2.0.0-0.1.rc5 - Update for new upstream tarball for release candidate: Pacemaker-2.0.0-rc5, for full details, see included ChangeLog file or https://github.com/ClusterLabs/pacemaker/releases/tag/Pacemaker-2.0.0-rc5 - Adapt spec file more akin to upstream version including: . new coreutils dependency for "post" scriptlet of -cli, for "mv" invocation (c2b16165d) * Wed May 16 2018 Jan Pokorný <jpokorny+rpm-pacemaker@redhat.com> - 2.0.0-0.1.rc4 - Update for new upstream tarball for release candidate: Pacemaker-2.0.0-rc4, for full details, see included ChangeLog file or https://github.com/ClusterLabs/pacemaker/releases/tag/Pacemaker-2.0.0-rc4 . as a special note, previous release candidate, rc3, had rolling upgrades broken, and if that is required, that particular release shall be skipped in the upgrade path altogether - Adapt spec file more akin to upstream version including: . as part of the update process, possibly move old log files as implicitly used prior to 2.0 so there's a (limited) continuity with the new implicit location, preventing clutter and confusion (ce2e74c99, c2b16165d) . move cts-exec-helper from -cli under main package (a2dc2a67e) . -cts backed with new helpers and, tangentially, dummy systemd service file transiently generated on-demand again (fa2d43445, d52b001b1) * Wed May 02 2018 Jan Pokorný <jpokorny+rpm-pacemaker@redhat.com> - 2.0.0-0.1.rc3 - Update for new upstream tarball for release candidate: Pacemaker-2.0.0-rc3, for full details, see included ChangeLog file or https://github.com/ClusterLabs/pacemaker/releases/tag/Pacemaker-2.0.0-rc3 . IMPORTANT: this release candidate, rc3, has rolling upgrades broken, and if that is required, this particular release shall be skipped in the upgrade path altogether - Adapt spec file more akin to upstream version including: . new --without legacy_links conditional (c8a7e5225) . reflect name change of the auxiliary daemons (e4f4a0d64, db5536e40, e2fdc2bac + 9ecbfea1c, 038c465e2 + ed8ce4055a) . new dummy systemd service for -cts (bf0a22812) . honor system-wide crypto policies once for all, via package-build-time configurable "pcmk_gnutls_priorities" defaulting to @SYSTEM as prescribed in https://fedoraproject.org/wiki/Packaging:CryptoPolicies (based on b3dfce1d3) - Adapt spec file akin to current packaging guidelines including: . make -nagios-plugins-metadata package noarch * Mon Apr 09 2018 Jan Pokorný <jpokorny+rpm-pacemaker@redhat.com> - 2.0.0-0.1.rc2 - Update for new upstream tarball for release candidate: Pacemaker-2.0.0-rc2, for full details, see included ChangeLog file or https://github.com/ClusterLabs/pacemaker/releases/tag/Pacemaker-2.0.0-rc2 - Adapt spec file more akin to upstream version including: . out-of-tree change from 1.1.18-2 build got subsumed (508ad52e7) . %{_sysconfdir}/pacemaker path got properly owned (-cli package; f6e3ab98d) . -libs package started to properly declare Requires(pre): shadow-utils (293fcc1e8 + b3d49d210) . some build conditionals and dependencies dropped for no longer (snmp, esmtp; f24bdc6f2 and 1f7374884, respectively) or never being relevant (~bison, byacc, flex; 61aef8af4) . some dependencies were constrained with new or higher lower bounds: corosync needs to be of version 2+ unconditionally (ccd58fe29), ditto some others components (~GLib, 1ac2e7cbb), plus both 2 and 3 versions of Python are now (comprehensively for the auxiliary functionality where used) supported upstream with the latter being a better fit (453355f8f) . package descriptions got to reflect the drop of legacy low-level cluster infrastructures (55ab749bf) - Adapt spec file akin to current packaging guidelines including: . drop some redundant/futile expressions (defattr, "-n %{name}-libs" instead of plain "libs", "timezone hack"), add some notes for future . make -cts and -doc packages noarch (former enabled with 088a5e7d4) . simplify "systemd_requires" macro invocation, and relax it to "systemd_ordering" for -remote package where possible so as not to drag systemd into a lightweight system setup (e.g. container) needlessly . adjust, in a compatible way, common ldconfig invocation with post{,un} scriptlets (https://fedoraproject.org/wiki/Changes/Removing_ldconfig_scriptlets) . drop some more unuseful conditionals (upstart_job) - Apply some regression fixes on top as patches (PR #1457, #1459) * Wed Feb 21 2018 Iryna Shcherbina <ishcherb@redhat.com> - 1.1.18-2.2 - Update Python 2 dependency declarations to new packaging standards (See https://fedoraproject.org/wiki/FinalizingFedoraSwitchtoPython3) * Thu Feb 08 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.18-2.1 - Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild * Thu Nov 16 2017 Jan Pokorný <jpokorny+rpm-pacemaker@redhat.com> - 1.1.18-2 - Make sure neither of pacemaker{,_remoted} is process-limited * Wed Nov 15 2017 Jan Pokorný <jpokorny+rpm-pacemaker@redhat.com> - 1.1.18-1 - Update for new upstream tarball: Pacemaker-1.1.18, for full details, see included ChangeLog file or https://github.com/ClusterLabs/pacemaker/releases/tag/Pacemaker-1.1.18 - Make -libs-devel package dependencies arch-qualified (-cts hasn't been switched at this time, pending further cleanup) * Fri Nov 03 2017 Jan Pokorný <jpokorny+rpm-pacemaker@redhat.com> - 1.1.18-0.1.rc4 - Update for new upstream tarball for release candidate: Pacemaker-1.1.18-rc4, for full details, see included ChangeLog file or https://github.com/ClusterLabs/pacemaker/releases/tag/Pacemaker-1.1.18-rc4 * Thu Oct 26 2017 Jan Pokorný <jpokorny+rpm-pacemaker@redhat.com> - 1.1.18-0.1.rc3 - Update for new upstream tarball for release candidate: Pacemaker-1.1.18-rc3, for full details, see included ChangeLog file or https://github.com/ClusterLabs/pacemaker/releases/tag/Pacemaker-1.1.18-rc3 * Mon Oct 16 2017 Jan Pokorný <jpokorny+rpm-pacemaker@redhat.com> - 1.1.18-0.1.rc2 - Update for new upstream tarball for release candidate: Pacemaker-1.1.18-rc2, for full details, see included ChangeLog file or https://github.com/ClusterLabs/pacemaker/releases/tag/Pacemaker-1.1.18-rc2 - Fix check scriptlet so as to work properly also with rpm<4.14 (not strictly required since: https://github.com/rpm-software-management/rpm/pull/249, but pragmatically follow the upstream) * Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.17-1.2 - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild * Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.17-1.1 - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild * Fri Jul 07 2017 Jan Pokorný <jpokorny+rpm-pacemaker@redhat.com> - 1.1.17-1 - Update for new upstream tarball: Pacemaker-1.1.17, for full details, see included ChangeLog file or https://github.com/ClusterLabs/pacemaker/releases/tag/Pacemaker-1.1.17 * Thu Jun 22 2017 Jan Pokorný <jpokorny+rpm-pacemaker@redhat.com> - 1.1.17-0.1.rc4 - Update for new upstream tarball for release candidate: Pacemaker-1.1.17-rc4, for full details, see included ChangeLog file or https://github.com/ClusterLabs/pacemaker/releases/tag/Pacemaker-1.1.17-rc4 - Add an imposed lower bound for glib2 BuildRequires * Thu Jun 01 2017 Jan Pokorný <jpokorny+rpm-pacemaker@redhat.com> - 1.1.17-0.1.rc3 - Update for new upstream tarball for release candidate: Pacemaker-1.1.17-rc3, for full details, see included ChangeLog file or https://github.com/ClusterLabs/pacemaker/releases/tag/Pacemaker-1.1.17-rc3 * Wed May 24 2017 Jan Pokorný <jpokorny+rpm-pacemaker@redhat.com> - 1.1.17-0.1.rc2 - Update for new upstream tarball for release candidate: Pacemaker-1.1.17-rc2, for full details, see included ChangeLog file or https://github.com/ClusterLabs/pacemaker/releases/tag/Pacemaker-1.1.17-rc2 * Tue May 09 2017 Jan Pokorný <jpokorny+rpm-pacemaker@redhat.com> - 1.1.17-0.1.rc1 - Update for new upstream tarball for release candidate: Pacemaker-1.1.17-rc1, for full details, see included ChangeLog file or https://github.com/ClusterLabs/pacemaker/releases/tag/Pacemaker-1.1.17-rc1