Mon, 06 Dec 2021 09:31:08 UTC

Information for build ruby-3.0.1-149.eln110

ID1757031
Package Nameruby
Version3.0.1
Release149.eln110
Epoch
Sourcegit+https://src.fedoraproject.org/rpms/ruby.git#6b2ff68f33447f7769ad8265b0dd966f007eab9c
SummaryAn interpreter of object-oriented scripting language
DescriptionRuby is the interpreted scripting language for quick and easy object-oriented programming. It has many features to process text files and to do system management tasks (as in Perl). It is simple, straight-forward, and extensible.
Built byjaruga
State complete
Volume DEFAULT
StartedTue, 01 Jun 2021 10:53:17 UTC
CompletedTue, 01 Jun 2021 11:32:26 UTC
Taskbuild (eln, /rpms/ruby.git:6b2ff68f33447f7769ad8265b0dd966f007eab9c)
Extra{'source': {'original_url': 'git+https://src.fedoraproject.org/rpms/ruby.git#6b2ff68f33447f7769ad8265b0dd966f007eab9c'}}
Tags No tags
RPMs
src
ruby-3.0.1-149.eln110.src.rpm (info) (download)
aarch64
ruby-3.0.1-149.eln110.aarch64.rpm (info) (download)
ruby-devel-3.0.1-149.eln110.aarch64.rpm (info) (download)
ruby-libs-3.0.1-149.eln110.aarch64.rpm (info) (download)
rubygem-bigdecimal-3.0.0-149.eln110.aarch64.rpm (info) (download)
rubygem-io-console-0.5.7-149.eln110.aarch64.rpm (info) (download)
rubygem-json-2.5.1-149.eln110.aarch64.rpm (info) (download)
rubygem-psych-3.3.0-149.eln110.aarch64.rpm (info) (download)
ruby-debuginfo-3.0.1-149.eln110.aarch64.rpm (info) (download)
ruby-debugsource-3.0.1-149.eln110.aarch64.rpm (info) (download)
ruby-libs-debuginfo-3.0.1-149.eln110.aarch64.rpm (info) (download)
rubygem-bigdecimal-debuginfo-3.0.0-149.eln110.aarch64.rpm (info) (download)
rubygem-io-console-debuginfo-0.5.7-149.eln110.aarch64.rpm (info) (download)
rubygem-json-debuginfo-2.5.1-149.eln110.aarch64.rpm (info) (download)
rubygem-psych-debuginfo-3.3.0-149.eln110.aarch64.rpm (info) (download)
i686
ruby-3.0.1-149.eln110.i686.rpm (info) (download)
ruby-devel-3.0.1-149.eln110.i686.rpm (info) (download)
ruby-libs-3.0.1-149.eln110.i686.rpm (info) (download)
rubygem-bigdecimal-3.0.0-149.eln110.i686.rpm (info) (download)
rubygem-io-console-0.5.7-149.eln110.i686.rpm (info) (download)
rubygem-json-2.5.1-149.eln110.i686.rpm (info) (download)
rubygem-psych-3.3.0-149.eln110.i686.rpm (info) (download)
ruby-debuginfo-3.0.1-149.eln110.i686.rpm (info) (download)
ruby-debugsource-3.0.1-149.eln110.i686.rpm (info) (download)
ruby-libs-debuginfo-3.0.1-149.eln110.i686.rpm (info) (download)
rubygem-bigdecimal-debuginfo-3.0.0-149.eln110.i686.rpm (info) (download)
rubygem-io-console-debuginfo-0.5.7-149.eln110.i686.rpm (info) (download)
rubygem-json-debuginfo-2.5.1-149.eln110.i686.rpm (info) (download)
rubygem-psych-debuginfo-3.3.0-149.eln110.i686.rpm (info) (download)
noarch
ruby-default-gems-3.0.1-149.eln110.noarch.rpm (info) (download)
ruby-doc-3.0.1-149.eln110.noarch.rpm (info) (download)
rubygem-bundler-2.2.15-149.eln110.noarch.rpm (info) (download)
rubygem-irb-1.3.5-149.eln110.noarch.rpm (info) (download)
rubygem-minitest-5.14.2-149.eln110.noarch.rpm (info) (download)
rubygem-power_assert-1.2.0-149.eln110.noarch.rpm (info) (download)
rubygem-rake-13.0.3-149.eln110.noarch.rpm (info) (download)
rubygem-rbs-1.0.4-149.eln110.noarch.rpm (info) (download)
rubygem-rdoc-6.3.0-149.eln110.noarch.rpm (info) (download)
rubygem-rexml-3.2.5-149.eln110.noarch.rpm (info) (download)
rubygem-rss-0.2.9-149.eln110.noarch.rpm (info) (download)
rubygem-test-unit-3.3.7-149.eln110.noarch.rpm (info) (download)
rubygem-typeprof-0.12.0-149.eln110.noarch.rpm (info) (download)
rubygems-3.2.15-149.eln110.noarch.rpm (info) (download)
rubygems-devel-3.2.15-149.eln110.noarch.rpm (info) (download)
ppc64le
ruby-3.0.1-149.eln110.ppc64le.rpm (info) (download)
ruby-devel-3.0.1-149.eln110.ppc64le.rpm (info) (download)
ruby-libs-3.0.1-149.eln110.ppc64le.rpm (info) (download)
rubygem-bigdecimal-3.0.0-149.eln110.ppc64le.rpm (info) (download)
rubygem-io-console-0.5.7-149.eln110.ppc64le.rpm (info) (download)
rubygem-json-2.5.1-149.eln110.ppc64le.rpm (info) (download)
rubygem-psych-3.3.0-149.eln110.ppc64le.rpm (info) (download)
ruby-debuginfo-3.0.1-149.eln110.ppc64le.rpm (info) (download)
ruby-debugsource-3.0.1-149.eln110.ppc64le.rpm (info) (download)
ruby-libs-debuginfo-3.0.1-149.eln110.ppc64le.rpm (info) (download)
rubygem-bigdecimal-debuginfo-3.0.0-149.eln110.ppc64le.rpm (info) (download)
rubygem-io-console-debuginfo-0.5.7-149.eln110.ppc64le.rpm (info) (download)
rubygem-json-debuginfo-2.5.1-149.eln110.ppc64le.rpm (info) (download)
rubygem-psych-debuginfo-3.3.0-149.eln110.ppc64le.rpm (info) (download)
s390x
ruby-3.0.1-149.eln110.s390x.rpm (info) (download)
ruby-devel-3.0.1-149.eln110.s390x.rpm (info) (download)
ruby-libs-3.0.1-149.eln110.s390x.rpm (info) (download)
rubygem-bigdecimal-3.0.0-149.eln110.s390x.rpm (info) (download)
rubygem-io-console-0.5.7-149.eln110.s390x.rpm (info) (download)
rubygem-json-2.5.1-149.eln110.s390x.rpm (info) (download)
rubygem-psych-3.3.0-149.eln110.s390x.rpm (info) (download)
ruby-debuginfo-3.0.1-149.eln110.s390x.rpm (info) (download)
ruby-debugsource-3.0.1-149.eln110.s390x.rpm (info) (download)
ruby-libs-debuginfo-3.0.1-149.eln110.s390x.rpm (info) (download)
rubygem-bigdecimal-debuginfo-3.0.0-149.eln110.s390x.rpm (info) (download)
rubygem-io-console-debuginfo-0.5.7-149.eln110.s390x.rpm (info) (download)
rubygem-json-debuginfo-2.5.1-149.eln110.s390x.rpm (info) (download)
rubygem-psych-debuginfo-3.3.0-149.eln110.s390x.rpm (info) (download)
x86_64
ruby-3.0.1-149.eln110.x86_64.rpm (info) (download)
ruby-devel-3.0.1-149.eln110.x86_64.rpm (info) (download)
ruby-libs-3.0.1-149.eln110.x86_64.rpm (info) (download)
rubygem-bigdecimal-3.0.0-149.eln110.x86_64.rpm (info) (download)
rubygem-io-console-0.5.7-149.eln110.x86_64.rpm (info) (download)
rubygem-json-2.5.1-149.eln110.x86_64.rpm (info) (download)
rubygem-psych-3.3.0-149.eln110.x86_64.rpm (info) (download)
ruby-debuginfo-3.0.1-149.eln110.x86_64.rpm (info) (download)
ruby-debugsource-3.0.1-149.eln110.x86_64.rpm (info) (download)
ruby-libs-debuginfo-3.0.1-149.eln110.x86_64.rpm (info) (download)
rubygem-bigdecimal-debuginfo-3.0.0-149.eln110.x86_64.rpm (info) (download)
rubygem-io-console-debuginfo-0.5.7-149.eln110.x86_64.rpm (info) (download)
rubygem-json-debuginfo-2.5.1-149.eln110.x86_64.rpm (info) (download)
rubygem-psych-debuginfo-3.3.0-149.eln110.x86_64.rpm (info) (download)
Logs
i686
hw_info.log
state.log
build.log
root.log
mock_output.log
noarch_rpmdiff.json
x86_64
hw_info.log
state.log
build.log
root.log
mock_output.log
noarch_rpmdiff.json
aarch64
hw_info.log
state.log
build.log
root.log
mock_output.log
noarch_rpmdiff.json
ppc64le
hw_info.log
state.log
build.log
root.log
mock_output.log
noarch_rpmdiff.json
s390x
hw_info.log
root.log
build.log
state.log
mock_output.log
noarch_rpmdiff.json
Changelog * Mon May 17 2021 Timm Bäder <tbaeder@redhat.com> - 3.0.1-149 - Pass ldflags to gem install via CONFIGURE_ARGS * Tue Apr 06 2021 Vít Ondruch <vondruch@redhat.com> - 3.0.1-148 - Upgrade to Ruby 3.0.1. * Thu Apr 01 2021 Vít Ondruch <vondruch@redhat.com> - 3.0.0-147 - Remove IRB dependency from rubygem-rdoc. * Tue Mar 02 2021 Vít Ondruch <vondruch@redhat.com> - 3.0.0-146 - Fix flaky excon test suite. - Properly support DWARF5 debug information. Resolves: rhbz#1920533 * Mon Jan 25 2021 Vít Ondruch <vondruch@redhat.com> - 3.0.0-145 - Bundle OpenSSL into StdLib. - Use proper path for plugin wrappers. * Sat Jan 16 2021 Vít Ondruch <vondruch@redhat.com> - 3.0.0-144 - Fix SEGFAULT in rubygem-shoulda-matchers test suite. * Tue Jan 12 2021 Vít Ondruch <vondruch@redhat.com> - 3.0.0-143 - Provide `gem.build_complete` file for binary gems. * Mon Jan 11 2021 Vít Ondruch <vondruch@redhat.com> - 3.0.0-142 - Re-enable test suite. * Fri Jan 08 2021 Vít Ondruch <vondruch@redhat.com> - 3.0.0-141 - ruby-default-gems have to depend on rubygem(io-console) due to reline. * Fri Jan 08 2021 Vít Ondruch <vondruch@redhat.com> - 3.0.0-140 - Fix SEGFAULT preventing rubygem-unicode to build on armv7hl. * Wed Jan 06 2021 Vít Ondruch <vondruch@redhat.com> - 3.0.0-139 - Add support for reworked RubyGems plugins. * Mon Jan 04 2021 Vít Ondruch <vondruch@redhat.com> - 3.0.0-138 - Upgrade to Ruby 3.0.0. - Extract RSS and REXML into separate subpackages, because they were moved from default gems to bundled gems. - Obsolete Net::Telnet and XMLRPC packages, because they were dropped from Ruby. * Tue Dec 15 2020 Pavel Valena <pvalena@redhat.com> - 2.7.2-137 - Add Recommends: redhat-rpm-config to devel subpackage. Resolves: rhbz#1905222 * Tue Nov 24 2020 Vít Ondruch <vondruch@redhat.com> - 2.7.2-136 - Add explicit `BR: make`. * Tue Oct 13 2020 Vít Ondruch <vondruch@redhat.com> - 2.7.2-135 - Upgrade to Ruby 2.7.2. * Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 2.7.1-134 - Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild * Mon Jul 27 2020 Vít Ondruch <vondruch@redhat.com> - 2.7.1-133 - Disable LTO, which appear to cause issues with SIGSEV handler. - Avoid possible timeout errors in TestBugReporter#test_bug_reporter_add. * Tue Jul 14 2020 Tom Stellard <tstellar@redhat.com> - 2.7.1-133 - Use make macros - https://fedoraproject.org/wiki/Changes/UseMakeBuildInstallMacro * Wed Jun 24 2020 Jun Aruga <jaruga@redhat.com> - 2.7.1-132 - Add ruby-default-gems dependency on irb. Resolves: rhbz#1850541 * Wed Jun 24 2020 Vít Ondruch <vondruch@redhat.com> - 2.7.1-132 - Fix `require` behavior allowing to load libraries multiple times. Resolves: rhbz#1835836 * Fri May 15 2020 Vít Ondruch <vondruch@redhat.com> - 2.7.1-131 - Relax rubygems-devel dependency on rubygems. * Wed Apr 08 2020 Vít Ondruch <vondruch@redhat.com> - 2.7.1-130 - Bundle did_you_mean into StdLib. Resolves: rhbz#1817178 - Prevent issues with openssl loading when RubyGems are disabled. * Thu Apr 02 2020 Vít Ondruch <vondruch@redhat.com> - 2.7.1-129 - Add ruby-default-gems subpackage shipping all extra default gem content. - Bundle Racc into StdLib. * Wed Apr 01 2020 Vít Ondruch <vondruch@redhat.com> - 2.7.1-128 - Upgrade to Ruby 2.7.1. - Fix FTBFS due to glibc 2.31.9000 implementing lchmod(2). * Tue Jan 28 2020 Vít Ondruch <vondruch@redhat.com> - 2.7.0-127 - Provide StdLib links for Racc and install it by default. * Thu Jan 16 2020 Vít Ondruch <vondruch@redhat.com> - 2.7.0-126 - Make rubygem(did_you_mean) hard dependency. * Tue Jan 07 2020 Vít Ondruch <vondruch@redhat.com> - 2.7.0-125 - Upgrade to Ruby 2.7.0. - Drop useless %{rubygems_default_filter}. * Tue Oct 08 2019 Slava Kardakov <ojab@ojab.ru> - 2.6.5-124 - Update to Ruby 2.6.5. * Fri Aug 30 2019 Pavel Valena <pvalena@redhat.com> - 2.6.4-123 - Update to Ruby 2.6.4. - Fix checksec 2.0+ compatibility. * Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2.6.3-122 - Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild * Tue Jun 25 2019 Vít Ondruch <vondruch@redhat.com> - 2.6.3-121 - Properly support %prerelease in %gemspec_ macros.