Fri, 03 Feb 2023 10:04:45 UTC

Information for build shim-15.6-2

ID1997554
Package Nameshim
Version15.6
Release2
Epoch
Sourcegit+https://src.fedoraproject.org/rpms/shim.git#e9a64acb97e5d371f736085c662fce58aad9eb4f
SummaryFirst-stage UEFI bootloader
DescriptionInitial UEFI bootloader that handles chaining to a trusted full bootloader under secure boot environments. This package contains the version signed by the UEFI signing service.
Built byrharwood
State complete
Volume DEFAULT
StartedThu, 07 Jul 2022 19:34:33 UTC
CompletedThu, 07 Jul 2022 19:37:25 UTC
Taskbuild (f35-build-side-54862, /rpms/shim.git:e9a64acb97e5d371f736085c662fce58aad9eb4f)
Extra{'source': {'original_url': 'git+https://src.fedoraproject.org/rpms/shim.git#e9a64acb97e5d371f736085c662fce58aad9eb4f'}}
Tags
coreos-pool
f35-updates
f36-updates
f36-updates-testing-pending
f37
f37-Beta
f37-updates-testing-pending
f38
RPMs
src
shim-15.6-2.src.rpm (info) (download)
aarch64
shim-aa64-15.6-2.aarch64.rpm (info) (download)
x86_64
shim-ia32-15.6-2.x86_64.rpm (info) (download)
shim-x64-15.6-2.x86_64.rpm (info) (download)
Logs
x86_64
hw_info.log
state.log
build.log
root.log
mock_output.log
aarch64
hw_info.log
state.log
build.log
root.log
mock_output.log
Changelog * Thu Jul 07 2022 Robbie Harwood <rharwood@redhat.com> - 15.6-2 - Update aarch64 (only) with relocation fixes - Resolves: #2101248 * Wed Jun 15 2022 Peter Jones <pjones@redhat.com> - 15.6-1 - Update to shim-15.6 Resolves: CVE-2022-28737 * Wed May 05 2021 Javier Martinez Canillas <javierm@redhat.com> - 15.4-5 - Bump release to build for F35 * Wed Apr 21 2021 Javier Martinez Canillas <javierm@redhat.com> - 15.4-4 - Fix handling of ignore_db and user_insecure_mode (pjones) - Fix booting on pre-UEFI Macs (pjones) - Fix mok variable storage allocation region (glin) Resolves: rhbz#1948432 - Fix the package version in the .sbat data (pjones) * Tue Apr 06 2021 Peter Jones <pjones@redhat.com> - 15.4-3 - Mark signed shim packages as protected in dnf. Resolves: rhbz#1874541 - Conflict with older fwupd, but don't require it. Resolves: rhbz#1877751 * Tue Apr 06 2021 Peter Jones <pjones@redhat.com> - 15.4-2 - Update to shim 15.4 - Support for revocations via the ".sbat" section and SBAT EFI variable - A new unit test framework and a bunch of unit tests - No external gnu-efi dependency - Better CI Resolves: CVE-2020-14372 Resolves: CVE-2020-25632 Resolves: CVE-2020-25647 Resolves: CVE-2020-27749 Resolves: CVE-2020-27779 Resolves: CVE-2021-20225 Resolves: CVE-2021-20233