Wed, 05 Oct 2022 19:15:03 UTC

Information for build perl-MooseX-Role-Strict-0.05-2.fc24

ID768431
Package Nameperl-MooseX-Role-Strict
Version0.05
Release2.fc24
Epoch
SummaryUse strict 'roles' in Moose
DescriptionWhen using Moose::Role, a class which provides a method a role provides will silently override that method. This can cause strange, hard-to-debug errors when the role's methods are not called. Simply use MooseX::Role::Strict instead of Moose::Role and overriding a role's method becomes a composition-time failure.
Built byeseyman
State complete
Volume fedora_koji_archive01
StartedThu, 26 May 2016 00:50:27 UTC
CompletedThu, 26 May 2016 00:53:29 UTC
Taskbuild (f24-candidate, /rpms/perl-MooseX-Role-Strict:f02fd969ab88772f60655a5ff44f2ddee091d2fa)
Tags
f24-updates
RPMs
src
perl-MooseX-Role-Strict-0.05-2.fc24.src.rpm (info) (download)
noarch
perl-MooseX-Role-Strict-0.05-2.fc24.noarch.rpm (info) (download)
Logs
noarch
build.log
root.log
state.log
Changelog * Wed May 25 2016 Emmanuel Seyman <emmanuel@seyman.fr> - 0.05-2 - Take into account review comments (#1338999) * Sun May 22 2016 Emmanuel Seyman <emmanuel@seyman.fr> - 0.05-1 - Specfile autogenerated by cpanspec 1.78.