Sun, 12 Jul 2020 20:54:35 UTC

Information for build gsoap-2.7.12-1.fc9

ID77497
Package Namegsoap
Version2.7.12
Release1.fc9
Epoch
SummaryGenerator Tools for Coding SOAP/XML Web Services in C and C++
DescriptionThe gSOAP Web services development toolkit offers an XML to C/C++ language binding to ease the development of SOAP/XML Web services in C and C/C++.
Built bymatt
State complete
Volume fedora_koji_archive00
StartedWed, 07 Jan 2009 05:44:33 UTC
CompletedWed, 07 Jan 2009 05:51:25 UTC
Taskbuild (dist-f9-updates-candidate, /cvs/pkgs:rpms/gsoap/F-9:gsoap-2_7_12-1_fc9)
Tags
dist-f9-updates
f9-build-cutoff
f9-cutoff
RPMs
src
gsoap-2.7.12-1.fc9.src.rpm (info) (download)
i386
gsoap-2.7.12-1.fc9.i386.rpm (info) (download)
gsoap-devel-2.7.12-1.fc9.i386.rpm (info) (download)
gsoap-debuginfo-2.7.12-1.fc9.i386.rpm (info) (download)
ppc
gsoap-2.7.12-1.fc9.ppc.rpm (info) (download)
gsoap-devel-2.7.12-1.fc9.ppc.rpm (info) (download)
gsoap-debuginfo-2.7.12-1.fc9.ppc.rpm (info) (download)
ppc64
gsoap-2.7.12-1.fc9.ppc64.rpm (info) (download)
gsoap-devel-2.7.12-1.fc9.ppc64.rpm (info) (download)
gsoap-debuginfo-2.7.12-1.fc9.ppc64.rpm (info) (download)
x86_64
gsoap-2.7.12-1.fc9.x86_64.rpm (info) (download)
gsoap-devel-2.7.12-1.fc9.x86_64.rpm (info) (download)
gsoap-debuginfo-2.7.12-1.fc9.x86_64.rpm (info) (download)
Logs
i386
build.log
root.log
state.log
ppc
build.log
root.log
state.log
ppc64
build.log
root.log
state.log
x86_64
build.log
root.log
state.log
Changelog * Wed Dec 24 2008 <matt@redhat> - 2.7.12-1 - Updated to gsoap 2.7.12: - Numerous bug fixes - xml:lang, maxOccurs="unbounded", SSL, xmlns="", ... - New features, maintaining backward compatibility - MinGW, wsseapi, multi-endpoint connect, ... - Patches removed (incorporated upstream): - datadir_importpath-2.7.10.patch - install_soapcpp2_wsdl2h_aux-2.7.10.patch - no_locale.patch as default off, enable by defining WITH_C_LOCALE - Patches added (sent upstream): - unused_args.patch - eliminate many unused param warnings * Thu Feb 21 2008 <mfarrellee@redhat> - 2.7.10-4 - Applied upd patch from upstream. It fixes glibc C locale issues, hp-ux h_errno definition, and xsd:dateTime timezone processing for WS-I - Removed tru64_hp_ux patches, they are present in upstream's upd patch - Added no_locale.patch to stop configure from checking for locale version of functions * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.7.10-3 - Autorebuild for GCC 4.3 * Mon Feb 18 2008 <mfarrellee@redhat> - 2.7.10-2 - Removed --disable-namespaces from configure, result is code compiled against gsoap does not need to call set_soap_namespaces * Sun Jan 27 2008 <mfarrellee@redhat> - 2.7.10-1 - Upgraded to 2.7.10 release - Stopped hosting patches on grid.et.redhat.com - Removed import_dom_h patch, it was integrated - Removed large autotools patch, replaced with patch (use_libtool-2.7.10.patch) changing configure.in, gsoap/Makefile.am and gsoap/wsdl/Makefile.am, which enable libtool use, and a call to autoreconf - Changed soapcpp2 references to gsoap as per new layout of source distribution - Updated tru64_hp_up_c/pp patches to handle new source layout - Install of soapcpp2/import with cp removed in favor of a patch to gsoap/Makefile.am (install_soapcpp2_wsdl2h_aux-2.7.10.patch) - No pre-generated Makefiles are distributed, no longer removing them - stdsoap2_cpp.cpp not in distribution, no longer removing it - Added datadir_importpath-2.7.10.patch to set SOAPCPP2_IMPORT_PATH and WSDL2H_IMPORT_PATH, useful defaults, using ${datadir} instead of `pwd` - Added autoconf, automake and libtool to BuildRequires, because configure.in and gsoap/Makefile.am are patched - Added ?dist to Release * Fri Nov 30 2007 <mfarrellee@redhat> - 2.7.9-0.4.l - Added OpenSSL requirement * Tue Nov 27 2007 <mfarrellee@redhat> - 2.7.9-0.3.l - Decided soapcpp2/import/ files should be in /usr/share instead of /usr/include because they are not really headers gcc can process. Also, this is likely the location new versions of gsoap will install the import headers. People should use -I /usr/share/gsoap/import * Mon Nov 26 2007 <mfarrellee@redhat> - 2.7.9-0.2.l - Changed license tag to GPLv2+, which is more accurate - Resolved bz399761 by adding soapcpp2/import/*.h to the -devel package as /usr/include/gsoap, users will need to add -I /usr/include/gsoap to their soapcpp2 line * Sun Sep 30 2007 <mfarrellee@redhat> - 2.7.9-0.1.l - Updated to 2.7.9l (2.7.9k patches still apply) - Added patch for import/dom.h missing xsd__anyAttribute definitions - Removed removal of .deps directories and autom4te.cache * Mon Sep 24 2007 <mfarrellee@redhat> - 2.7.9-0.2.k - Moved pkgconfig requirement to -devel package * Tue Sep 11 2007 <mfarrellee@redhat> - 2.7.9-0.1.k - Initial release