Sun, 20 Sep 2020 05:59:18 UTC

Information for RPM python3-straight-plugin-1.5.0-1.fc26.noarch.rpm

ID13844449
Namepython3-straight-plugin
Version1.5.0
Release1.fc26
Epoch
Archnoarch
SummaryPython plugin loader
Descriptionstraight.plugin is a Python plugin loader inspired by twisted.plugin with two important distinctions: - Fewer dependencies - Python 3 compatible The system is used to allow multiple Python packages to provide plugins within a namespace package, where other packages will locate and utilize. The plugins themselves are modules in a namespace package where the namespace identifies the plugins in it for some particular purpose or intent.
Build Time2018-04-27 08:47:48 GMT
Size19,648
2328077171aeaf3280b8c0f40fb4e053
LicenseBSD
Buildrootf26-build-12234737-900349
Provides
python3-straight-plugin = 1.5.0-1.fc26
python3.6dist(straight.plugin) = 1.5.0
python3dist(straight.plugin) = 1.5.0
Obsoletes No Obsoletes
Conflicts No Conflicts
Requires
python(abi) = 3.6
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(PayloadIsXz) <= 5.2-1
Recommends No Recommends
Suggests No Suggests
Supplements No Supplements
Enhances No Enhances
Files
1 through 19 of 19
Name ascending sort Size
/usr/lib/python3.6/site-packages/straight4,096
/usr/lib/python3.6/site-packages/straight.plugin-1.5.0-py3.6-nspkg.pth549
/usr/lib/python3.6/site-packages/straight.plugin-1.5.0-py3.6.egg-info4,096
/usr/lib/python3.6/site-packages/straight.plugin-1.5.0-py3.6.egg-info/PKG-INFO441
/usr/lib/python3.6/site-packages/straight.plugin-1.5.0-py3.6.egg-info/SOURCES.txt6,790
/usr/lib/python3.6/site-packages/straight.plugin-1.5.0-py3.6.egg-info/dependency_links.txt1
/usr/lib/python3.6/site-packages/straight.plugin-1.5.0-py3.6.egg-info/namespace_packages.txt9
/usr/lib/python3.6/site-packages/straight.plugin-1.5.0-py3.6.egg-info/top_level.txt9
/usr/lib/python3.6/site-packages/straight/plugin4,096
/usr/lib/python3.6/site-packages/straight/plugin/__init__.py66
/usr/lib/python3.6/site-packages/straight/plugin/__pycache__4,096
/usr/lib/python3.6/site-packages/straight/plugin/__pycache__/__init__.cpython-36.opt-1.pyc188
/usr/lib/python3.6/site-packages/straight/plugin/__pycache__/__init__.cpython-36.pyc188
/usr/lib/python3.6/site-packages/straight/plugin/__pycache__/loaders.cpython-36.opt-1.pyc5,573
/usr/lib/python3.6/site-packages/straight/plugin/__pycache__/loaders.cpython-36.pyc5,573
/usr/lib/python3.6/site-packages/straight/plugin/__pycache__/manager.cpython-36.opt-1.pyc2,258
/usr/lib/python3.6/site-packages/straight/plugin/__pycache__/manager.cpython-36.pyc2,258
/usr/lib/python3.6/site-packages/straight/plugin/loaders.py5,577
/usr/lib/python3.6/site-packages/straight/plugin/manager.py1,878
Component of No Buildroots