Wed, 16 Oct 2019 12:47:50 UTC

Information for RPM pcre2-10.32-5.fc30.ppc64le.rpm

ID16139308
Namepcre2
Version10.32
Release5.fc30
Epoch
Archppc64le
SummaryPerl-compatible regular expression library
DescriptionPCRE2 is a re-working of the original PCRE (Perl-compatible regular expression) library to provide an entirely new API. PCRE2 is written in C, and it has its own API. There are three sets of functions, one for the 8-bit library, which processes strings of bytes, one for the 16-bit library, which processes strings of 16-bit values, and one for the 32-bit library, which processes strings of 32-bit values. There are no C++ wrappers. This package provides support for strings in 8-bit and UTF-8 encodings. Install pcre2-utf16 or pcre2-utf32 packages for the other ones. The distribution does contain a set of C wrapper functions for the 8-bit library that are based on the POSIX regular expression API (see the pcre2posix man page). These can be found in a library called libpcre2posix. Note that this just provides a POSIX calling interface to PCRE2; the regular expressions themselves still follow Perl syntax and semantics. The POSIX API is restricted, and does not give full access to all of PCRE2's facilities.
Build Time2019-01-03 14:09:45 GMT
Size230848
9c9cc94ff31b75bc772ecedc112f34c3
LicenseBSD
Buildrootf30-build-14798455-1052873
Provides
bundled(sljit)
libpcre2-8.so.0()(64bit)
libpcre2-posix.so.2()(64bit)
pcre2 = 10.32-5.fc30
pcre2(ppc-64) = 10.32-5.fc30
Obsoletes No Obsoletes
Conflicts No Conflicts
Requires
libc.so.6()(64bit)
libc.so.6(GLIBC_2.17)(64bit)
libpcre2-8.so.0()(64bit)
libpthread.so.0()(64bit)
libpthread.so.0(GLIBC_2.17)(64bit)
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(PayloadIsXz) <= 5.2-1
rtld(GNU_HASH)
Recommends No Recommends
Suggests No Suggests
Supplements No Supplements
Enhances No Enhances
Files
1 through 16 of 16
Name ascending sort Size
/usr/lib/.build-id0
/usr/lib/.build-id/0d0
/usr/lib/.build-id/0d/c092c895a643b476b5998971f5097fd015445e41
/usr/lib/.build-id/880
/usr/lib/.build-id/88/42253b18c0d660b000ba4bcb9de9198fedeb2c45
/usr/lib64/libpcre2-8.so.019
/usr/lib64/libpcre2-8.so.0.7.1602424
/usr/lib64/libpcre2-posix.so.223
/usr/lib64/libpcre2-posix.so.2.0.167896
/usr/share/doc/pcre20
/usr/share/doc/pcre2/AUTHORS728
/usr/share/doc/pcre2/ChangeLog87879
/usr/share/doc/pcre2/NEWS9510
/usr/share/licenses/pcre20
/usr/share/licenses/pcre2/COPYING97
/usr/share/licenses/pcre2/LICENCE3456
Component of
Page:
1 through 50 of 32605 >>>
Buildroot descending sort Created State
f30-build-15001474-1067684 2019-01-24 13:58:16 expired
f30-build-14995305-1068608 2019-01-23 14:00:51 expired
f30-build-14995289-1068608 2019-01-23 13:57:04 expired
f30-build-14995285-1068608 2019-01-23 13:57:02 expired
f30-build-14995266-1068608 2019-01-23 13:52:44 expired
f30-build-14995257-1068608 2019-01-23 13:48:55 expired
f30-build-14995252-1068608 2019-01-23 13:48:53 expired
f30-build-14995250-1068608 2019-01-23 13:48:33 expired
f30-build-14995248-1068608 2019-01-23 13:48:30 expired
f30-build-14995242-1068608 2019-01-23 13:48:22 expired
f30-build-14995241-1068608 2019-01-23 13:48:18 expired
f30-build-14995238-1068608 2019-01-23 13:48:14 expired
f30-build-14995233-1068608 2019-01-23 13:47:45 expired
f30-build-14995217-1068608 2019-01-23 13:45:25 expired
f30-ruby-14995209-1068607 2019-01-23 13:44:58 expired
f30-build-14995202-1068608 2019-01-23 13:44:04 expired
f30-build-14995201-1068608 2019-01-23 13:43:47 expired
f30-build-14995200-1068608 2019-01-23 13:43:44 expired
f30-build-14995195-1068608 2019-01-23 13:43:17 expired
f30-build-14995192-1068608 2019-01-23 13:43:14 expired
f30-build-14995186-1068608 2019-01-23 13:42:58 expired
f30-build-14995181-1068608 2019-01-23 13:40:21 expired
f30-build-14995178-1068608 2019-01-23 13:40:19 expired
f30-build-14995171-1068608 2019-01-23 13:40:06 expired
f30-build-14995170-1068608 2019-01-23 13:40:02 expired
f30-build-14995161-1068608 2019-01-23 13:39:35 expired
f30-build-14995160-1068608 2019-01-23 13:39:17 expired
f30-build-14995143-1068608 2019-01-23 13:38:21 expired
f30-build-14995137-1068608 2019-01-23 13:38:20 expired
f30-build-14995136-1068608 2019-01-23 13:38:14 expired
f30-build-14995130-1068608 2019-01-23 13:38:08 expired
f30-ruby-14995120-1068607 2019-01-23 13:35:17 expired
f30-build-14995105-1068608 2019-01-23 13:33:48 expired
f30-build-14995098-1068608 2019-01-23 13:32:28 expired
f30-build-14995082-1068608 2019-01-23 13:32:02 expired
f30-build-14995074-1068608 2019-01-23 13:31:37 expired
f30-build-14995057-1068596 2019-01-23 13:30:32 expired
f30-build-14995039-1068596 2019-01-23 13:25:38 expired
f30-build-14995037-1068591 2019-01-23 13:25:35 expired
f30-build-14995029-1068596 2019-01-23 13:25:16 expired
f30-build-14995028-1068596 2019-01-23 13:25:13 expired
f30-build-14995021-1068591 2019-01-23 13:22:54 expired
f30-build-14995019-1068591 2019-01-23 13:22:47 expired
f30-build-14995014-1068591 2019-01-23 13:21:33 expired
f30-build-14995000-1068591 2019-01-23 13:20:52 expired
f30-build-14994997-1068591 2019-01-23 13:20:41 expired
f30-build-14994989-1068591 2019-01-23 13:20:18 expired
f30-build-14994979-1068591 2019-01-23 13:19:49 expired
f30-build-14994963-1068591 2019-01-23 13:18:52 expired
f30-build-14994937-1068591 2019-01-23 13:17:18 expired