Mon, 18 Nov 2019 21:49:22 UTC

Information for RPM vim-X11-2:8.1.818-1.fc28.armv7hl.rpm

ID16289480
Namevim-X11
Version8.1.818
Release1.fc28
Epoch2
Archarmv7hl
SummaryThe VIM version of the vi editor for the X Window System - GVim
DescriptionVIM (VIsual editor iMproved) is an updated and improved version of the vi editor. Vi was the first real screen-based editor for UNIX, and is still very popular. VIM improves on vi by adding new features: multiple windows, multi-level undo, block highlighting and more. VIM-X11 is a version of the VIM editor which will run within the X Window System. If you install this package, you can run VIM as an X application with a full GUI interface and mouse support by command gvim. Install the vim-X11 package if you'd like to try out a version of vi with graphics and mouse capabilities. You'll also need to install the vim-common package.
Build Time2019-01-25 09:58:30 GMT
Size1436476
762cf4e50f63b51c9a5427772aedeb42
LicenseVim and MIT
Buildrootf28-build-15008029-1070021
Provides
/usr/bin/gvim
/usr/bin/mergetool
application()
application(gvim.desktop)
gvim = 8.1.818-1.fc28
metainfo()
metainfo(gvim.appdata.xml)
mimehandler(application/x-shellscript)
mimehandler(text/english)
mimehandler(text/plain)
mimehandler(text/x-c)
mimehandler(text/x-c++)
mimehandler(text/x-c++hdr)
mimehandler(text/x-c++src)
mimehandler(text/x-chdr)
mimehandler(text/x-csrc)
mimehandler(text/x-java)
mimehandler(text/x-makefile)
mimehandler(text/x-moc)
mimehandler(text/x-pascal)
mimehandler(text/x-tcl)
mimehandler(text/x-tex)
vim-X11 = 2:8.1.818-1.fc28
vim-X11(armv7hl-32) = 2:8.1.818-1.fc28
Obsoletes No Obsoletes
Conflicts No Conflicts
Requires
/bin/sh
gtk3
hicolor-icon-theme
ld-linux-armhf.so.3
ld-linux-armhf.so.3(GLIBC_2.4)
libICE.so.6
libSM.so.6
libX11.so.6
libXt.so.6
libacl.so.1
libacl.so.1(ACL_1.0)
libattr >= 2.4
libc.so.6
libc.so.6(GLIBC_2.11)
libc.so.6(GLIBC_2.15)
libc.so.6(GLIBC_2.4)
libcairo.so.2
libdl.so.2
libdl.so.2(GLIBC_2.4)
libgcc_s.so.1
libgcc_s.so.1(GCC_3.5)
libgdk-3.so.0
libgdk_pixbuf-2.0.so.0
libgio-2.0.so.0
libglib-2.0.so.0
libgobject-2.0.so.0
libgpm.so.2
libgtk-3.so.0
libm.so.6
libm.so.6(GLIBC_2.4)
libpango-1.0.so.0
libpangocairo-1.0.so.0
libpthread.so.0
libpthread.so.0(GLIBC_2.4)
libselinux.so.1
libtinfo.so.6
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(PayloadIsXz) <= 5.2-1
rtld(GNU_HASH)
vim-common = 2:8.1.818-1.fc28
Recommends No Recommends
Suggests
lua-libs
perl(:MODULE_COMPAT_5.26.3)
perl-devel
perl-libs
python2
python2-libs
python3
python3-libs
ruby
ruby-libs
Supplements No Supplements
Enhances No Enhances
Files
1 through 20 of 20
Name ascending sort Size
/usr/bin/evim4
/usr/bin/gex4
/usr/bin/gview4
/usr/bin/gvim3108752
/usr/bin/gvimdiff4
/usr/bin/gvimtutor143
/usr/bin/vimtutor2121
/usr/bin/vimx4
/usr/lib/.build-id0
/usr/lib/.build-id/650
/usr/lib/.build-id/65/7b7b48f281f0d30d08eb35c784102fa8a9996e24
/usr/share/applications/gvim.desktop3819
/usr/share/icons/hicolor/16x16/apps/gvim.png226
/usr/share/icons/hicolor/32x32/apps/gvim.png347
/usr/share/icons/hicolor/48x48/apps/gvim.png474
/usr/share/icons/hicolor/64x64/apps/gvim.png4485
/usr/share/icons/locolor/16x16/apps/gvim.png226
/usr/share/icons/locolor/32x32/apps/gvim.png347
/usr/share/man/man1/evim.1.gz789
/usr/share/metainfo/gvim.appdata.xml1203
Component of No Buildroots