Sat, 29 Feb 2020 04:16:04 UTC

Information for RPM perl-threads-1:2.22-449.module_f31+7931+b513465b.s390x.rpm

ID20555302
Nameperl-threads
Version2.22
Release449.module_f31+7931+b513465b
Epoch1
Archs390x
SummaryPerl interpreter-based threads
DescriptionSince Perl 5.8, thread programming has been available using a model called interpreter threads which provides a new Perl interpreter for each thread, and, by default, results in no data or state information being shared between threads. (Prior to Perl 5.8, 5005threads was available through the Thread.pm API. This threading model has been deprecated, and was removed as of Perl 5.10.0.) As just mentioned, all variables are, by default, thread local. To use shared variables, you need to also load threads::shared.
Build Time2020-02-14 09:59:38 GMT
Size62,789
7ff5f5e3a973cf25f6ba319192fafa7f
LicenseGPL+ or Artistic
Buildrootmodule-perl-bootstrap-5.30-3120200214084245-f636be4b-build-19398778-1362099
Provides
perl(threads) = 2.22
perl-threads = 1:2.22-449.module_f31+7931+b513465b
perl-threads(s390-64) = 1:2.22-449.module_f31+7931+b513465b
Obsoletes No Obsoletes
Conflicts No Conflicts
Requires
libc.so.6()(64bit)
libc.so.6(GLIBC_2.2)(64bit)
libc.so.6(GLIBC_2.4)(64bit)
libperl.so.5.30()(64bit)
libpthread.so.0()(64bit)
libpthread.so.0(GLIBC_2.2)(64bit)
perl(:MODULE_COMPAT_5.30.1)
perl(:VERSION) >= 5.8.0
perl(Config)
perl(XSLoader)
perl(overload)
perl(strict)
perl(warnings)
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(PayloadIsZstd) <= 5.4.18-1
rtld(GNU_HASH)
Recommends No Recommends
Suggests No Suggests
Supplements No Supplements
Enhances No Enhances
Files
1 through 6 of 6
Name ascending sort Size
/usr/lib/.build-id0
/usr/lib/.build-id/7f/439932f31cbc04503f3f88259039ed01fe411751
/usr/lib64/perl5/auto/threads0
/usr/lib64/perl5/auto/threads/threads.so44,592
/usr/lib64/perl5/threads.pm37,942
/usr/share/man/man3/threads.3pm.gz14,255
Component of
1 through 6 of 6
Buildroot descending sort Created State
module-perl-bootstrap-5.30-3120200214084245-f636be4b-build-19399251-1362131 2020-02-14 10:36:55 expired
module-perl-bootstrap-5.30-3120200214084245-f636be4b-build-19399238-1362131 2020-02-14 10:36:16 expired
module-perl-bootstrap-5.30-3120200214084245-f636be4b-build-19399228-1362131 2020-02-14 10:36:02 expired
module-perl-bootstrap-5.30-3120200214084245-f636be4b-build-19399222-1362131 2020-02-14 10:35:55 expired
module-perl-bootstrap-5.30-3120200214084245-f636be4b-build-19399209-1362131 2020-02-14 10:35:34 expired
module-perl-bootstrap-5.30-3120200214084245-f636be4b-build-19399206-1362131 2020-02-14 10:35:32 expired